Back to godoc.org

Package dashboardGraphOwl

v3.14.0+incompatible
Latest Go to latest

The latest major version is .

Published: Dec 21, 2017 | License: Apache-2.0 | Module: github.com/Cepave/open-falcon-backend

Index

func CreateGraph

func CreateGraph(c *gin.Context)

func DeleteGraph

func DeleteGraph(c *gin.Context)

func GetGraph

func GetGraph(c *gin.Context)

func Routes

func Routes(r *gin.Engine)

func UpdateGraph

func UpdateGraph(c *gin.Context)

type APICreateGraphInput

type APICreateGraphInput struct {
	Title     string `json:"title" binding:"required"`
	Hosts     string `json:"hosts" binding:"required"`
	Counters  string `json:"counters" binding:"required"`
	ScreenId  int64  `json:"screen_id" binding:"required"`
	Timespan  int64  `json:"timespan"`
	GraphType string `json:"graph_type"`
	Method    string `json:"method"`
}

type APIGetGraphOutput

type APIGetGraphOutput struct {
	ID        string `json:"id" binding:"required"`
	Title     string `json:"titile" binding:"required"`
	Hosts     string `json:"hosts" binding:"required"`
	Counters  string `json:"counters" binding:"required"`
	Timespan  int64  `json:"timespan"`
	GraphType string `json:"graph_type"`
	Method    string `json:"method"`
	ScreenId  int64  `json:"screen_id" binding:"required"`
}

type APIUpdateGraphInput

type APIUpdateGraphInput struct {
	ID        int64  `json:"id" binding:"required"`
	Title     string `json:"title" binding:"required"`
	Hosts     string `json:"hosts" binding:"required"`
	Counters  string `json:"counters" binding:"required"`
	Timespan  int64  `json:"timespan"`
	GraphType string `json:"graph_type"`
	Method    string `json:"method"`
	ScreenId  int64  `json:"screen_id" binding:"required"`
}

Package Files

Documentation was rendered with GOOS=linux and GOARCH=amd64.

Jump to identifier

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to identifier