version

package
Version: v2.14.3+incompatible Latest Latest
Warning

This package is not in the latest version of its module.

Go to latest
Published: Jul 30, 2019 License: Apache-2.0 Imports: 4 Imported by: 0

Documentation

Overview

Package version represents the current version of the project.

Index

Constants

This section is empty.

Variables

View Source
var (
	// Version is the current version of the Helm.
	// Update this whenever making a new release.
	// The version is of the format Major.Minor.Patch[-Prerelease][+BuildMetadata]
	//
	// Increment major number for new feature additions and behavioral changes.
	// Increment minor number for bug fixes and performance enhancements.
	// Increment patch number for critical fixes to existing releases.
	Version = "v2.14"

	// BuildMetadata is extra build time data
	BuildMetadata = "unreleased"
	// GitCommit is the git sha1
	GitCommit = ""
	// GitTreeState is the state of the git tree
	GitTreeState = ""
)

Functions

func GetVersion

func GetVersion() string

GetVersion returns the semver string of the version

func GetVersionProto

func GetVersionProto() *version.Version

GetVersionProto returns protobuf representing the version

func IsCompatible

func IsCompatible(client, server string) bool

IsCompatible tests if a client and server version are compatible.

func IsCompatibleRange

func IsCompatibleRange(constraint, ver string) bool

IsCompatibleRange compares a version to a constraint. It returns true if the version matches the constraint, and false in all other cases.

Types

This section is empty.

Jump to

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to
y or Y : Canonical URL