kubernetes

package
Version: v4.2.2+incompatible Latest Latest
Warning

This package is not in the latest version of its module.

Go to latest
Published: Sep 17, 2018 License: Apache-2.0 Imports: 12 Imported by: 6

Documentation

Index

Constants

This section is empty.

Variables

This section is empty.

Functions

func NewKubernetesFactory

func NewKubernetesFactory(logger lager.Logger, clientset *kubernetes.Clientset, namespacePrefix string) *kubernetesFactory

func NewKubernetesManagerFactory

func NewKubernetesManagerFactory() creds.ManagerFactory

Types

type Kubernetes

type Kubernetes struct {
	Clientset       *kubernetes.Clientset
	TeamName        string
	PipelineName    string
	NamespacePrefix string
	// contains filtered or unexported fields
}

func (Kubernetes) Get

func (k Kubernetes) Get(varDef template.VariableDefinition) (interface{}, bool, error)

func (Kubernetes) List

type KubernetesManager

type KubernetesManager struct {
	InClusterConfig bool   `long:"in-cluster" description:"Enables the in-cluster client."`
	ConfigPath      string `long:"config-path" description:"Path to Kubernetes config when running ATC outside Kubernetes."`
	NamespacePrefix string `` /* 137-byte string literal not displayed */
}

func (KubernetesManager) Health

func (manager KubernetesManager) Health() (*creds.HealthResponse, error)

func (KubernetesManager) Init

func (manager KubernetesManager) Init(log lager.Logger) error

func (KubernetesManager) IsConfigured

func (manager KubernetesManager) IsConfigured() bool

func (*KubernetesManager) MarshalJSON

func (manager *KubernetesManager) MarshalJSON() ([]byte, error)

func (KubernetesManager) NewVariablesFactory

func (manager KubernetesManager) NewVariablesFactory(logger lager.Logger) (creds.VariablesFactory, error)

func (KubernetesManager) Validate

func (manager KubernetesManager) Validate() error

Jump to

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to
t or T : Toggle theme light dark auto
y or Y : Canonical URL