Back to godoc.org
github.com/goodrain/rainbond/cmd/api/option

package option

v3.6.1+incompatible
Latest Go to latest
Published: Jul 11, 2018 | License: LGPL-3.0 | Module: github.com/goodrain/rainbond

Index

type APIServer

type APIServer struct {
	Config
	LogLevel       string
	StartRegionAPI bool
}

APIServer apiserver server

func NewAPIServer

func NewAPIServer() *APIServer

NewAPIServer new server

func (*APIServer) AddFlags

func (a *APIServer) AddFlags(fs *pflag.FlagSet)

AddFlags config

func (*APIServer) SetLog

func (a *APIServer) SetLog()

SetLog 设置log

type Config

type Config struct {
	DBType            string
	APIAddr           string
	APIAddrSSL        string
	DBConnectionInfo  string
	EventLogServers   []string
	NodeAPI           []string
	BuilderAPI        []string
	EntranceAPI       []string
	V1API             string
	MQAPI             string
	KubeConfig        string
	EtcdEndpoint      []string
	APISSL            bool
	APICertFile       string
	APIKeyFile        string
	WebsocketSSL      bool
	WebsocketCertFile string
	WebsocketKeyFile  string
	WebsocketAddr     string
	Opentsdb          string
	RegionTag         string
	LoggerFile        string
	Debug             bool
}

Config config

Documentation was rendered with GOOS=linux and GOARCH=amd64.

Jump to identifier

Keyboard shortcuts

? : This menu
f or F : Jump to identifier