wsapi

package
Version: v5.11.1+incompatible Latest Latest
Warning

This package is not in the latest version of its module.

Go to latest
Published: Jun 11, 2019 License: AGPL-3.0, Apache-2.0 Imports: 6 Imported by: 0

Documentation

Index

Constants

This section is empty.

Variables

This section is empty.

Functions

func Init

func Init(a *app.App, router *app.WebSocketRouter)

func NewInvalidWebSocketParamError

func NewInvalidWebSocketParamError(action string, name string) *model.AppError

Types

type API

type API struct {
	App    *app.App
	Router *app.WebSocketRouter
}

func (*API) ApiWebSocketHandler

func (api *API) ApiWebSocketHandler(wh func(*model.WebSocketRequest) (map[string]interface{}, *model.AppError)) webSocketHandler

func (*API) InitStatus

func (api *API) InitStatus()

func (*API) InitSystem

func (api *API) InitSystem()

func (*API) InitUser

func (api *API) InitUser()

Jump to

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to
t or T : Toggle theme light dark auto
y or Y : Canonical URL