fac

command module
v2.0.0+incompatible Latest Latest
Warning

This package is not in the latest version of its module.

Go to latest
Published: Jun 15, 2018 License: MIT Imports: 12 Imported by: 0

README ¶


Easy-to-use CUI for fixing git conflicts


I never really liked any of the mergetools out there so I made a program that is somewhat easier to use.

Preview

👷 Installation

Execute:

$ go get github.com/mkchoi212/fac

Or using Homebrew 🍺

brew tap mkchoi212/fac https://github.com/mkchoi212/fac.git
brew install fac

🔧 Using

fac operates much like git add -p . It has a prompt input at the bottom of the screen where the user inputs various commands.

The commands have been preset to the following specifications

w - show more lines up
s - show more lines down
a - use local version
d - use incoming version
e - manually edit code

j - scroll down
k - scroll up

v - [v]iew orientation
n - [n]ext conflict
p - [p]revious conflict

h | ? - [h]elp
q | Ctrl+c - [q]uit

[w,a,s,d,?] >> [INPUT HERE]

⚙️ Customization

The above key-bindings and various behaviors can be altered by creating a .fac.yml file in your home directory. Please refer to the configuration README.md for more information.

✋ Contributing

This is an open source project so feel free to contribute by

👮 License

See License

Documentation ¶

The Go Gopher

There is no documentation for this package.

Directories ¶

Path Synopsis

Jump to

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to
y or Y : Canonical URL