mailmsg

package module
v0.0.2 Latest Latest
Warning

This package is not in the latest version of its module.

Go to latest
Published: Feb 17, 2015 License: MIT Imports: 4 Imported by: 0

README

mailmsg

Go (golang) package for creating/formatting mail (RFC822, RFC5322) messages

Current version: 0.0.1

This package is a work in progress. This is not a fully compliant formatter, but eventually we would like it to be.

If you need a message parser, we recommend the Go standard library net/mail package.

Eventually we'd like to support MIME (RFC2045, RFC2046, RFC2047, RFC4288, [RFC4289][] and RFC2049).

Install

TBD

Usage

TBD

Documentation

Index

Constants

This section is empty.

Variables

This section is empty.

Functions

func BuildNumber

func BuildNumber() int64

func Version

func Version() string

Types

type InternetMessageFormat

type InternetMessageFormat struct {
	// contains filtered or unexported fields
}

currently do nothing but naive formatting.

func New

func New() *InternetMessageFormat

Create a new, empty message

func (*InternetMessageFormat) AddHeader

func (imf *InternetMessageFormat) AddHeader(field_name, field_body string) error

func (*InternetMessageFormat) Bytes

func (imf *InternetMessageFormat) Bytes() []byte

Format the message according to the appropriate RFC

func (*InternetMessageFormat) SetBody

func (imf *InternetMessageFormat) SetBody(message_body []byte) error

Jump to

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to
y or Y : Canonical URL