errors

package
Version: v1.14.6 Latest Latest
Warning

This package is not in the latest version of its module.

Go to latest
Published: Aug 16, 2019 License: Apache-2.0, Apache-2.0 Imports: 3 Imported by: 0

Documentation

Overview

Package errors contains utilities for admission webhook specific errors

Index

Constants

This section is empty.

Variables

This section is empty.

Functions

func NewDryRunUnsupportedErr added in v1.12.0

func NewDryRunUnsupportedErr(webhookName string) *apierrors.StatusError

NewDryRunUnsupportedErr returns a StatusError with information about the webhook plugin

func ToStatusErr

func ToStatusErr(webhookName string, result *metav1.Status) *apierrors.StatusError

ToStatusErr returns a StatusError with information about the webhook plugin

Types

This section is empty.

Jump to

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to
y or Y : Canonical URL