Back to godoc.org

Package clients

v3.6.1+incompatible
Latest Go to latest

The latest major version is .

Published: Jul 11, 2018 | License: LGPL-3.0 | Module: github.com/goodrain/rainbond

Index

Variables

var K8SClient *kubernetes.Clientset

K8SClient K8SClient

var NodeClient *region.RNodeClient

NodeClient node api

var RegionClient *region.Region

RegionClient region api

func InitClient

func InitClient(kubeconfig string) error

InitClient init k8s client

func InitNodeClient

func InitNodeClient(nodeAPI string) error

InitNodeClient init node api client

func InitRegionClient

func InitRegionClient(reg option.RegionAPI) error

InitRegionClient init region api client

Documentation was rendered with GOOS=linux and GOARCH=amd64.

Jump to identifier

Keyboard shortcuts

? : This menu
/ : Search site
f or F : Jump to identifier